How to define timeout correctly in config files?


#1

I tried setting the timeout parameter to 60 in the config file, but cayley doesn’t seem to care. Any ideas what I might be doing wrong?

I’m using 0.7.0-alpha and the config file looks like this:

store:
  # backend to use
  backend: bolt
  # address or path for the database
  address: "./data/cayley_test.db"
  # open database in read-only mode
  read_only: false
  # backend-specific options
  options:
    nosync: false
timeout: 60
load:
  ignore_duplicates: false
  ignore_missing: false
  batch: 10000

#2

Timeout is specified in Golang duration syntax, thus 60 seconds should be written as 60s. This should work.


#3

It cuts off the query after 30.00x sec even with the 60s each time. Thanks for the reply


#4

Okay, I will double-check this


#5

Fixed. Timeout should be specified as

query:
  timeout: 30s